Client Support
cancel

The dataset with id 'IM' is not available when connecting Trim 7.1 Client even locally

Highlighted
Jansen Brown
New Member.

The dataset with id 'IM' is not available when connecting Trim 7.1 Client even locally

Hi,

 

I just had to remove our TRIM server from a domain, and add it to another. Now it does not sem to allow connections to it or its dataset, even though the service is running on the server. Here is the error :

 

[23347] Client Machine: SERVER2; Client User: N/A

The dataset with id 'IM' is not available. Possible causes are: it is registered on a different HP TRIM Workgroup Server to the one currently selected, the schema of this dataset is not supported by this workgroup or the network connection between the workgroup and the database server has failed.. This error message will not be displayed again today.

 

[22737] Client Machine: SERVER2.domain.local; Client User: administrator

Error connecting to TRIM dataset 'COMPANY_TRIM' on workgroup SERVER2. Remote: The dataset with id 'IM' is not available. Possible causes are: it is registered on a different HP TRIM Workgroup Server to the one currently selected, the schema of this dataset is not supported by this workgroup or the network connection between the workgroup and the database server has failed.

 

[23347] Client Machine: SERVER2; Client User: N/A

Could not access database COMPANY_TRIM, this database will not be supported. Details: The schema of this database (0) is not supported by this HP TRIM Workgroup Server. You will need to upgrade your database scheme in order to access it... This error message will not be displayed again today.

 

Any Ideas???

 

 

2 REPLIES
Grundy
Acclaimed Contributor.

Re: The dataset with id 'IM' is not available when connecting Trim 7.1 Client even locally

Moving the TRIM server from one domain to another is no small change in an environment like this.

If you were using Windows Authentication to connect to the database, this will probably be failing now, and all your users must also be authenticated in the same domain as the Workgroup server.

 

There's quite a few places where you may have broken some account authentication, so it's a matter of starting at one end and working your way back, e.g. ensure the TRIM Enterprise Studio is configured and working. (The service starting is no indication that it's "working"), remove then re-add the dataset, check how it authenticates to the database server, ensure the accounts running the services are available in the new domain and have the correct access on all the servers involved etc.

 

Then work back to clients, make sure they are authenticating on the new domain correctly and so on...



::::::::::::::::::::::
NOT A HP EMPLOYEE
::::::::::::::::::::::

INFORMOTION.com.au
TRIMGuru
Acclaimed Contributor.

Re: The dataset with id 'IM' is not available when connecting Trim 7.1 Client even locally

To add what Grundy has said, I can reiterate, like he did, to ensure to delete the dataset from the new TRIM enterprise studio, then re-add it and using the log on for that database with the new domain name.  PLUS ensure there's the new log on's for the TRIM Workgroup services that matches the new domain.