Client Support
cancel
Showing results for 
Search instead for 
Did you mean: 

TRIM Web Client (7.34) Preview Error Due to ASCII Code Conversion

SOLVED
Go to solution
Highlighted

TRIM Web Client (7.34) Preview Error Due to ASCII Code Conversion

On some documents accessed through the TRIM Web Client, the Preview Window displays an error message stating "Could not find file 'D:\HPTRIM\WebServerWorkPath\htmlpreview\26\<Title>.html'.", where <Title> is the HP TRIM record title.  In these cases, the TRIM record title contains an "En dash" character (ASCII 96h), rather than the short dash or hyphen (ASCII 2Dh).  When viewing the document, a temporary file is created on the server, with the name <Title>.html.  The En Dash character in the file name is replaced by a set of three characters, which are  – or <Latin-small-letter-a-with-circumflex><Euro-sign><Left-double-quotation-mark> or ASCII E2h 80h 93h.  This seems like a code page conversion, but I can't figure out why. If I supercopy the record to a folder on the server, the file name is generated correctly.  Everything else in the TRIM Web Client handles the En Dash character correctly, including the message in the Preview window saying the file cannot be found.  -- That is correct, it can't be found, because the filename within the temporary folder does not match what the Web Client is looking for.  This seems like a bug to me. Or, does someone know of a way to solve it? 

 

Environment: Windows 2008 R2 Server; IIS 7.5; Windows 7; IE 10.

 

Thanks!

 

6 REPLIES
Greg Fraser_1
HPE Expert

Re: TRIM Web Client (7.34) Preview Error Due to ASCII Code Conversion

Hi Carol.

 

Would it be possible to get a sample document to test with?

**Any opinions expressed in this forum are my own personal opinion and should not be interpreted as an official statement on behalf of Hewlett Packard Enterprise**

Re: TRIM Web Client (7.34) Preview Error Due to ASCII Code Conversion

Attached is a sample Word 2010 document containing an En Dash.  If you save it into TRIM as a new record (using Office integration), you will see that the title contains the same En Dash.  This is something we do in our environment, and since the title of the document is sometimes a reasonable title for the record too, the En Dash character is often retained as part of the record title.  Note that we do not use the En Dash character explicitly.  Word, by default, converts <space><hyphen><space> into <En Dash>.  (Word also converts two hyphens surrounded by spaces to En Dash, and two hyphens NOT surrounded by spaces to an <Em Dash> character [ASCII 97h].) 

 

Thanks Greg!

 

 

Greg Fraser_1
HPE Expert

Re: TRIM Web Client (7.34) Preview Error Due to ASCII Code Conversion

Hi Carol,

 

I just registered that document into TRIM 7.34 via drag and drop. Office 2010 64 bit was installed.

 

And the preview page looks fine to me:

 

 

I had a look and could not find any similar issues.

Is this the same error that all your users see?

**Any opinions expressed in this forum are my own personal opinion and should not be interpreted as an official statement on behalf of Hewlett Packard Enterprise**

Re: TRIM Web Client (7.34) Preview Error Due to ASCII Code Conversion

Greg,

 

A couple of differences -- first of all, I didn't register the document using drag and drop.  I used save as from Word 2010.  Secondly, everything is just fine in the TRIM rich client.  It is the web client where the problem appears.

 

Thanks!

 

Greg Fraser_1
HPE Expert
Solution

Re: TRIM Web Client (7.34) Preview Error Due to ASCII Code Conversion

Ah, sorry I missed the Webclient reference in the title.

 

Just installed and tested with the webclient and received the error that you have mentioned.

 

"Could not find file"

 

Works fine if drag and drop was used.

 

I'll write something up and submit it through to R&D for their review.

**Any opinions expressed in this forum are my own personal opinion and should not be interpreted as an official statement on behalf of Hewlett Packard Enterprise**
Greg Fraser_1
HPE Expert

Re: TRIM Web Client (7.34) Preview Error Due to ASCII Code Conversion

Hi Carol,

 

Just as an FYI I have tested with RM 8.1 and Office 2010 and the problem was not there. Looks like it only occurs in 7.34.

**Any opinions expressed in this forum are my own personal opinion and should not be interpreted as an official statement on behalf of Hewlett Packard Enterprise**
//Add this to "OnDomLoad" event