cancel

Client Connection Timeout Settings

SOLVED
Go to solution
Highlighted
T0mTran
Honored Contributor.

Client Connection Timeout Settings

Hi,

 

We noticed in RM Client > Help > Setup Information, there are two settings: Network(RCF) Client Call Timeout and Network(RCF) Client Connection Timeout.


a. What is the unit of these two settings?
b. How can we modify these settings?

 

Thanks,

14 REPLIES
Greg Fraser_1
HPE Expert

Re: Client Connection Timeout Settings

The value will be in milliseconds.

 

Not sure where to change the values, I'll do some research. 

 

The client call timeout is the important one and it is set to 20mins which is plenty. 

**Any opinions expressed in this forum are my own personal opinion and should not be interpreted as an official statement on behalf of Hewlett Packard Enterprise**
Greg Fraser_1
HPE Expert
Solution

Re: Client Connection Timeout Settings

OK, the only key you will need to change is:

 

‘Network(RCF) client connection timeout’  which by default its 5000 milliseconds.

 

To change the client needs to add the following registry key one each client machine:

  • HKLM->Software->Hewlett-Packard->HP TRIM->WorkgroupServerConnection.
  • Add a DWORD (32bit) Value called ‘rcfClientConnectTimeout’.
  • Enter a Decimal value equal to the amount of millisecond that you wish to set the timeout to.
**Any opinions expressed in this forum are my own personal opinion and should not be interpreted as an official statement on behalf of Hewlett Packard Enterprise**
jheer
Trusted Contributor.

Re: Client Connection Timeout Settings

Hi Greg,

I tried adding that registry keys you mentioned but the values in setup information still show as 1200000.  

Most values I've found stored in HKCU rather than HKLM.  Can you confirm if HKLM is the correct location?

I'm using HP RM 8.1.1

Thanks!

Jason

Greg Fraser_1
HPE Expert

Re: Client Connection Timeout Settings

1200000 sound like plenty to me that's 20 minutes. What are you trying to change it to?

Are you getting the RCF timeout errors

**Any opinions expressed in this forum are my own personal opinion and should not be interpreted as an official statement on behalf of Hewlett Packard Enterprise**
jheer
Trusted Contributor.

Re: Client Connection Timeout Settings

28800000 (8 hours).  I'll give you some context:

Since we upgraded to version 8.1.1 from 7, we've been struggling with application slowness.  We worked with HP Support and discovered a known issue with the TRIMwatcher that was resolved by a patch.  Our users still continue to struggle with application hanging/slowness that was not present in our previous version.

Symptoms:

Users will launch HPE Records Manager, leave it open, work on other things, come back to the application after 20 minutes and try to click within the application but the blue processing circle spins and spins, finishes spinning then users can continue using HPE Records manager.  

What's interesting is that when I check TES, I can see that all users logon time has updated to within the last 20 minutes even though they logged in at the start of their shift and left the client open.  Logically one would think after a user has launched the application and created a conneciton, left it open, it would maintain their connection until they close the application but that doesn't seem to be the case with the new version.  In version 7 when I would check TES, it would maintain the correct user logon time so  I'm not sure what if any improvements were made in version 8.1.1 but it has caused us a lot of grief and users have lost confidence in HPE.   

At this point we're wililng to try anything to improve the user experience and I believe it has to do with the connection dropped and re-connecting.  The 20 minute connection limit seems very closely related to the delay users experience when trying to run some activity within the application.

I was trying to test your suggestion for increasing the connection timeout to see if it made any difference but updating the HKLM registry entry did not work.  I have a ticket open with HP Support as well. Maybe the value/location has changed?

If you have any ideas or heard of similar issues I'd appreciate any advice you can offer.

Thank you

Greg Fraser_1
HPE Expert

Re: Client Connection Timeout Settings

Those are the correct key locations, not sure if it has a max value though. Try something just slightly larger than the default  and see if that sticks.

More importantly we should pin down what is causing the client to take so long to open. If you open a client on the WGS itself are there the same delays? Are you WGS remote? and what kind of network connection do they have.

**Any opinions expressed in this forum are my own personal opinion and should not be interpreted as an official statement on behalf of Hewlett Packard Enterprise**
jheer
Trusted Contributor.

Re: Client Connection Timeout Settings

I tried adding the registry values to a client install.  Oddly the HKLM values were not present so I manually created them, then wiped out the HKCU keys but still no luck.  I tried changing the reg. keys on a workgroup server, launched the client and it stuck.

No idea why the values are sticking on the workgroup server but not a regular desktop client install?

Our workgroup servers are not remote.  We have a (10GB fibre channel) network connection.  I should mention we are using the same architecture and never had any issues with v7.1 until we upgraded to 8.1.  If I run a Performance index - latency check, it returns a value of about 650.  When I run the performance test on a workgroup server, it returns a value of 3747, which is expected but the difference seems quite high?

I haven't tried working off a workgruop server itself but will see if I can reproduce the issue.

By default is the HKLM\SOFTWARE\Hewlett-Packard\HP TRIM\ keys present for 8.1 installs, more importantly should they be?

 

Greg Fraser_1
HPE Expert

Re: Client Connection Timeout Settings

If it is working on the WGS then you know the key works, you'll need to figure out why it is not sticking on the client.

Is there anything different about the client end compared to the WGS, eg are you connecting through a termial services or Citrix setup?

If you are really stuck, log a support case and we can get some logs and go into some deeper detail.

**Any opinions expressed in this forum are my own personal opinion and should not be interpreted as an official statement on behalf of Hewlett Packard Enterprise**
jheer
Trusted Contributor.

Re: Client Connection Timeout Settings

The only difference between the WGS and client is that we are using a patched client 8.1.1..8013 but the WGS is 8.1.1.7760.

We are using regular conneciton, no terminal services or Citrix.

I have a support case open with HP 5311212267 but the last update I got was:

"The registry key have to be updated on your server and you just need to restart the HPRM Enterprise studio."

But if the registry changes are meant for the desktop client machine, I'm not sure if that is the correct solution?  Just can't figure out why the desktop client machines won't recognize the values.

 

Greg Fraser_1
HPE Expert

Re: Client Connection Timeout Settings

Can you attach some screenshots of the keys you've created so i can take a look?

**Any opinions expressed in this forum are my own personal opinion and should not be interpreted as an official statement on behalf of Hewlett Packard Enterprise**
jheer
Trusted Contributor.

Re: Client Connection Timeout Settings

Desktop Client Registry ValuesDesktop Client Registry ValuesDesktop Client Screenshot of ValuesDesktop Client Screenshot of ValuesWGS Registry ValuesWGS Registry ValuesWGS Screenshot of ValuesWGS Screenshot of Values

Greg Fraser_1
HPE Expert

Re: Client Connection Timeout Settings

Not sure why the WGS hold the changes and the client doesn't but you ahve the values the wrong way around.

Client connection timeout is the one you should be changing:

  • HKLM->Software->Hewlett-Packard->HP TRIM->WorkgroupServerConnection.
  • Add a DWORD (32bit) Value called ‘rcfClientConnectTimeout’.
  • Enter a Decimal value equal to the amount of millisecond that you wish to set the timeout to.

Those screens look like you've changed the call timeout

**Any opinions expressed in this forum are my own personal opinion and should not be interpreted as an official statement on behalf of Hewlett Packard Enterprise**
jheer
Trusted Contributor.

Re: Client Connection Timeout Settings

Hi Greg,

Figured out what the issue was.  HP Support did a webex and informed me the registry location for our install needs to point to Wow6432Node instead of the root of HKLM:

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Hewlett-Packard\HP TRIM\WorkgroupServerConnection]
"rcfClientConnectTimeout"=dword:002ab980

Thanks for all your help!

Jason

Greg Fraser_1
HPE Expert

Re: Client Connection Timeout Settings

Ah right, glad to hear you got it going.

**Any opinions expressed in this forum are my own personal opinion and should not be interpreted as an official statement on behalf of Hewlett Packard Enterprise**