cancel

Classification Copy Style Behavior

Highlighted
Diana McMullin
Trusted Contributor.

Classification Copy Style Behavior

In TRIM 6.1 when creating a new classification the copy style defaults to referenced when following these steps.

1)      Right click | New | Top Level

2)      Give it a number (i.e., Test1, Test2, etc)

3)      At New Top Level window, enter name (i.e., Test1, Test2, etc) (normally I also enter manager, home location, retention but for testing, not necessary)

4)      Click Default Record Access button – copy defaults to Not Reference, Not Copied

5)      Assign security level

6)      Tag all Access Controls

7)      Click Custom button | Restricted | Remove my name

8)      Add | Records Management | OK – At this point the copy style changes to Reference (this is what we want)

 

If you re-open the classifications and look a the copy style tab in custom access controls, the "Apply this access control in addition to any access control on the item (Referenced)" is marked. This is what we want.

 

In TRIM 7.02 the behavior is slightly diffrent. After repeating the steps 1-8, the following error is displayed.

"Access Control: View Document, View Metadata, Update Document, Update Record Metadata, Modify Record Access, Destroy Record, Contribute Contents is redundant. Either set details to 'Public' or set 'copy style' to Referenced and/or Copy."

 

How do we set the 'Referenced' as a default setting in TRIM 7.02?

 

 

3 REPLIES
TRIMGuru
Acclaimed Contributor.

Re: Classification Copy Style Behavior

I don't have 7.02 installed yet, still using 7.01.

 

But after following the instructions and after completing these steps:

 

5)      Assign security level

6)      Tag all Access Controls

7)      Click Custom button | Restricted | Remove my name

8)      Add | Records Management | OK – At this point the copy style changes to Reference (this is what we want)

 

I then clicked the Copy Style tab and selected :

 

Apply this access control in addition to any access control on the item (Referenced)

 

AND

 

Set access control on the created item to 'Everyone"

 

Once I clicked OK, then the Copy Style showed as "Reference"

 

 

It really is going to depend on exactly what type of access control you want, I would suspect you'd want "Reference, Copy To Item"

 

 

Diana McMullin
Trusted Contributor.

Re: Classification Copy Style Behavior

Guru,

So are you saying it just won't do it automatically anymore? That tab was always there in the past, the RM staff just didn't have to stop and think about clicking the box in 6.1 because it miraculously did it for them.

Diana

TRIMGuru
Acclaimed Contributor.

Re: Classification Copy Style Behavior

The first screen I'm attaching, shows the screen right after I click the default Record Access button.  The second screen shows right after I changed the Security Level.  The third screen shows after I selected all, clicked on Custom, removed my name and added the Group Administration, then clicked on OK without going to the Copy Style tab.

 

So, there's nothing automatically changing that I see.