Client Automation Standard Practitioners Forum
cancel

HPCM Admin Publisher - user ID problem

Highlighted
DBO_1
Regular Contributor.

HPCM Admin Publisher - user ID problem

Hello,

I am deploying HPCM5.11 on a network. As I started some packaging using the Publisher tool, I got a weird error whenever I try to log in using the default account RAD_MAST: "INVALID USER ID"
I have restarted all the services, the server, and tried different logins (rad_sys and so on), it still won't let me go through.
It used to work for about 20mn before I started the Publisher again and got this error. The CSDB editor will also give me the same error message.

This is really impacting the progress of my deployement, any help ?

Thank you
6 REPLIES
Alexander Willn
Acclaimed Contributor.

Re: HPCM Admin Publisher - user ID problem

Well, error message does clearly say that user name is unknown. Either someone did modify admin instances in RCS DB or you're connecting to a different RCS - did you verify that, e.g. having a look inot log files?
DBO_1
Regular Contributor.

Re: HPCM Admin Publisher - user ID problem

Thanks. This is a default install and I didn't edit the RCS. A quick look at zmaster tells me it's pointing to the proper DB, and there is only one on the machine.

According to the log, the users don't exist anymore, but I would rather think it has troubles accessing the DB.
Alexander Willn
Acclaimed Contributor.

Re: HPCM Admin Publisher - user ID problem

Did you navigate through directory structure of your RCS db? Does a file RAD_MAST exist under DB\PRIMARY\ADMIN\ADMINID?
DBO_1
Regular Contributor.

Re: HPCM Admin Publisher - user ID problem

Alex,
No "Admin" folder in the PRIMARY folder of the DB. I assume something got corrupted, so I've reinstalled the whole configuration server and reconfigured it.
I just tried to log back : I got through, so problem solved :-)

Thanks for your reactivity, have a great day,
Damien
DBO_1
Regular Contributor.

Re: HPCM Admin Publisher - user ID problem

Okay, for those who may get the same error in the future:

-Backup the RCS DB
-Reinstall the Configuration server
-Stop the CS service
-Copy the ADMIN folder from the new DB to the old one (the backup)
-Restore the old RCS DB

And voila, it should work.
Steve Berube
Outstanding Contributor.

Re: HPCM Admin Publisher - user ID problem

This should probably be in the CAEnterprise forum, 5.11 isn't a CAS version