The community will be in read-only from Tuesday 11:59pm (PST) to Wednesday noon (PST)
The community will be in read-only from Tuesday 11:59pm (PST) to Wednesday noon (PST)
Client Automation Standard Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Failed to deploy software inventory on installed devices

SOLVED
Go to solution
Highlighted
bharath_hanuma
Collector

Failed to deploy software inventory on installed devices

Hi All,

This is bharath here, we am facing one problem w.r.t CCM 7.20 application running on Microsoft SQL server 2005 database on windows server 2003 platform. Whenever we are going to deploy software inventory or patch compliance or application usage we are getting error which is pasted as below.

Software/Hardware Inventory Wizard Complete 0 out of 1 discovery jobs successfully created. Device discovery Job failed to be created for '1 Device(s)'

Need your urgent help in resolving the issue.

Waiting for your reply @ the earliest....

Thanks & Regards
Bharath
2 REPLIES
Steve Berube
Frequent Visitor
Solution

Re: Failed to deploy software inventory on installed devices

Please post logs from your \Novadigm\ClientConfigurationManager\logs folder.

If you see an error regarding no threads available, most likely its due to a corrupt Jobs.ckpt file under ManagementPortal/etc/jobs.ckpt

A quick solution is to 1. stop httpd-rmp service. 2. Backup your jobs.ckpt file 3. copy jobs.ckpt.old to jobs.ckpt 4. restart httpd-rmp
Providing the backup file isn't corrupt either, that should get you back up and running. IF that doesn't work, you can delete the jobs.ckpt and a new one will get created, but you will lose all existing jobs.
bharath_hanuma
Collector

Re: Failed to deploy software inventory on installed devices

Thank u steve for your correct solution....

Best Regards
Bharath
//Add this to "OnDomLoad" event