The community will be in read-only from Tuesday 11:59pm (PST) to Wednesday noon (PST)
The community will be in read-only from Tuesday 11:59pm (PST) to Wednesday noon (PST)
Client Automation Standard Practitioners Forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Agent Installation Problem

Highlighted
HP services
Regular Collector

Agent Installation Problem

I am trying to deploy agent manually, But it is shooting up error that i have given in attachment
6 REPLIES
Karl Skelton
Honored Contributor

Re: Agent Installation Problem

Check the CAS guide and ensure you have all the relevant Ports\Firewall settings open.
Also ensure that you specify valid account\pw when running the agent install from the CAS server.
HP services
Regular Collector

Re: Agent Installation Problem

I am using this Command for manual installation at Client machine:-

C:\RadAgent\setup.cmd host(IP), where host (10.249.36.39) is the IP
address or hostname of HPCAS server
Karl Skelton
Honored Contributor

Re: Agent Installation Problem

I don't understand the relevance of the screenshot - from the CAS console - to the manual install of the Agent!

For the manual install... you copied the Radagent folder to the client device and ran the install from there?

What error conditions do you get on the client side?

Karl.
HP services
Regular Collector

Re: Agent Installation Problem

The snapshot & error message given in attachment is for the remote installation.

Karl Skelton
Honored Contributor

Re: Agent Installation Problem

Sorry but this doesn't make sense.
The screenshot is from the CAS server for a job initiated at the CAS server to do a client install.
You don't get such a job when you install the client remotely using setup.cmd!
I just tried it. The client installs perfectly and there was no job to be seen.

Karl.
HP services
Regular Collector

Re: Agent Installation Problem

I am attaching the error message details that i am getting while doing maual installtion of Agent:-
This is the error message that i am getting :-
D:\RadAgent>IF "10.249.16.38" == "" GOTO NOIPADDR

D:\RadAgent>SET CCMSYSTEMDRIVE=C:

D:\RadAgent>IF NOT "C:" == "" GOTO SYSTEMDRIVEOK

D:\RadAgent>IF "" == "" GOTO OS32BIT

D:\RadAgent>SET NVD_DIR=C:\Program Files\Hewlett-Packard\CM

D:\RadAgent>SET INSTALL_DIR=C:\Program Files\Hewlett-Packard\CM\Agent

D:\RadAgent>SET AGENT_DIR=C:\Program Files\Hewlett-Packard\CM\ManagementAgent

D:\RadAgent>IF NOT EXIST "C:\Program Files\Hewlett-Packard\CM" MD "C:\Program Fi
les\Hewlett-Packard\CM"

D:\RadAgent>IF NOT EXIST "C:\Program Files\Hewlett-Packard\CM\ManagementAgent" M
D "C:\Program Files\Hewlett-Packard\CM\ManagementAgent"

D:\RadAgent>copy "D:\RadAgent\\rma\nvdkit.exe" "C:\Program Files\Hewlett-Packard
\CM\ManagementAgent"
1 file(s) copied.

D:\RadAgent>copy "D:\RadAgent\\rma\rma.tkd" "C:\Program Files\Hewlett-Packard\CM
\ManagementAgent"
1 file(s) copied.

D:\RadAgent>"D:\RadAgent\\client\setup.exe" NVDOBJZMASTER_ZIPADDR=10.249.16.38 /
qb!

D:\RadAgent>"C:\Program Files\Hewlett-Packard\CM\Agent\radconct" mode=discovery


D:\RadAgent>"C:\Program Files\Hewlett-Packard\CM\ManagementAgent\nvdkit" "C:\Pro
gram Files\Hewlett-Packard\CM\ManagementAgent/rma.tkd/bin/rma-mgt.tcl" install -
url http://10.249.16.38:3466/proc/rmp
20090410 16:39:34 Info: module C:/Program Files/Hewlett-Packard/CM/ManagementAge
nt/rma.tkd
16:39:34 Info: rma: installing service
16:39:34 Warning: The system cannot find the file specified. (0x2)
16:39:39 Info: rma: installing service
16:39:46 Warning: The system cannot find the file specified. (0x2)
16:39:51 Info: rma: installing service
16:39:51 Warning: The system cannot find the file specified. (0x2)
16:39:56 Error: The system cannot find the file specified. (0x2), abandoning

D:\RadAgent>goto END

D:\RadAgent>Echo.


D:\RadAgent>Echo Installation completed successfully.
Installation completed successfully.

D:\RadAgent>EXIT /B 0

D:\RadAgent>
//Add this to "OnDomLoad" event