Application Perf Mgmt (BAC / BSM) Practitioners Forum

upgarde BSM 9.01 to BSM 9.1 failed

Acclaimed Contributor

upgarde BSM 9.01 to BSM 9.1 failed


I want to upgarde my BSM to 9.1.

I didn't want to mess up the production env so i created test servers and copied the DB.


In the start of the upgarde i got this error:

[mercury][Oracle JDBC Driver]No more data available to read

I solved this by changeing the connection pool-Maximum connection timeout value to 1800000 (30 min).


There where some privillages issues on the DB which i solved and also i needed to delete the index HISTLINETIMECHANGEDINDEX on event schema

and also delete some columns from the HISTORY_LINE and EVENT_FORWARD tables.


The problem now is that after all of this changes i still get this error of "no more data..."

the first time i changed the timeout was through the UI of the PROD servers and then i copied the DB again to the test.

now i dont want to copy the DB again..

so does any on know where can i find this settings in the DB?

and also how much timeout i should configure?






Asaf Shechter
HPE Expert

Re: upgrade BSM 9.01 to BSM 9.1 failed


what you are trying to achieve is not supported. BSM9.0 to 9.1x upgrade is supported only in Direct mode, which means using the same servers and the same DBs (in the DB we store the server name, so connecting BSM on other server might cause issues with connecting to the DB). You should first perform the DR process to fix your DBs with your new servers.

I also recommend to run the omi-archive tool to clear closed events. It might help.

If you still have issues I suggest to open support case.

Regular Collector

Re: upgrade BSM 9.01 to BSM 9.1 failed



I think he is trying to achive a direct upgrade, but on a test environment. In this case, before proceeding with anything, if the Test environment is an exact replica of the Production one - always start with the database migration. Meaning - make sure the new databases don't have references to the old DB server!


Then proceed with the upgrade.




Acclaimed Contributor

Re: upgrade BSM 9.01 to BSM 9.1 failed


sorry but I forgot to mention that I changed the servers and the DB name in the copied DB.

So yes what I am trying to do is a direct upgrade on the copied DB.


this part is working OK and I have been managed to change those values.


anyway the problem I have is not talking about the name of the servers or the DB it is only a timeout..

Acclaimed Contributor

Re: upgrade BSM 9.01 to BSM 9.1 failed

does anyone know what to do with this error?

//Add this to "OnDomLoad" event