Application Perf Mgmt (BAC / BSM) Practitioners Forum
Showing results for 
Search instead for 
Did you mean: 

SSH Key Remote Unix Server Connection Fails

Chris Winkler
Occasional Advisor

SSH Key Remote Unix Server Connection Fails

I am receiving a connection error when trying to setup a  Remote Unix Server and using Keyfile as the SSH Authorization method.

Steps I am following:
1. On the Sitescope server, launch Mindterm and Create KeyPair.
2. Copy the private key file(identity) into the Sitescope\Groups folder on the Sitescope server. Copy the public file up to the remote unix server into the .ssh directory in my profile and rename it to “authorized_keys2”
3. On the remote unix server, change permissions of the .ssh directory by running chmod 777 .ssh
4. In Sitescope, create a new Unix Remote Server
5. In the Advanced Setting, I select Keyfile as the Authentication method. I then provide the location of the private key file(Sitescope\Groups\identity

When I click on "Save and Test", I get an error message that reads "SSH v2 connect failed   remote command error (-1)".
The following error gets thrown in the RunMonitor.log file:

internalConnectV2: Failed SSH V2 connect Permission denied



Additional Info:
• I have tried selecting and deselecting the "SSH Version 2 only", "SSH keep alive mechanism", "Disable connection cache" options, but still recieve the same error.
• I have tried creating DSA and RSA keypairs, with both 1024 and 2048 key lengths and also with and without OpenSSH .pub format selected.
• I am using Sitescope for Load Testing version 11.10

Does anyone have any suggestions on how I can successfully create the Remote Unix Server using SSH Keys?



Frequent Visitor

Re: SSH Key Remote Unix Server Connection Fails

Hi Chris



Not sure if this applies to your case, but we found that we need to use OpenSSH keys in particular for Sitescope to successfully connect to a Unix/ Linux machine with key authentication. It didn't work for us when we tried generating keys with puttygen for some reason.


Just out of interest, could you try copying the authorized_keys2 to authorized_keys and give it another go? Also, could you post a screenshot of your remote machine config in Sitescope? Only the last section will suffice.




Chris Winkler
Occasional Advisor

Re: SSH Key Remote Unix Server Connection Fails

That worked! I renamed authorized_keys2 to authorized_keys and was able to connect successfully. Thank you.



Frequent Visitor

Re: SSH Key Remote Unix Server Connection Fails

Ah cool, glad that worked. Apparently the authorized_keys2 file is only used for older SSH instances, which is a bit counter-intuitive as you'd think anything named 2 would be a sequel, not a prequel (applying some movie logic here hehe).


If you run into any other issues, just shout.

//Add this to "OnDomLoad" event