Application Perf Mgmt (BAC / BSM) Practitioners Forum

HP SiteScope DB2 Monitor

Outstanding Contributor.

HP SiteScope DB2 Monitor

Dear Experts,

We are currently using SiteScope 11.22 installed on RHEL.

I am currently trying to configure the database so that SIteScope is able to retrieve the counters.

In the "Monitor Reference" document, it says that this monitor uses the Snapshot mirroring functionality supported by DB2.

And that I must enable the Snapshot Mirror on the DB2 instance in order to retrieve the counters.


Not sure if this is the right place to ask this question, but does anyone know how to enable the Snapshot mirroring functionality or at least know how to check to see if it is enabled or not?


The current status when I run the tool for the DB2 monitor is as follows:

Step 1:Attempting to Locate Driver Class...

Step 2:Attempting to Load Driver Class...

Step 3: Attempting to Connect to Database...
***ERROR***: ***ERROR***:
Exception Message: [jcc][t4][2043][11550][3.64.106] Exception Error opening socket to server xxxxxxxxx/ on port 50,000 with message: Connection refused. ERRORCODE=-4499, SQLSTATE=08001


Any advice on this is very much appreciated.







Micro Focus Expert

Re: HP SiteScope DB2 Monitor


On which OS is DB2 running? Snapshot mirroring is not supported in zOS so this monitor won't work if DB2 runs on that. Anyways that will throw different error about counters...

What you have here is a SQL error thrown at connection time:

Connection refused. ERRORCODE=-4499, SQLSTATE=08001

These links may help you:
Kenneth Gonzalez
HP Support

If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.

If you haven’t tried it yet, come and join us in our entitled forums at Support Customer Forums
Outstanding Contributor.

Re: HP SiteScope DB2 Monitor

The OS that the DB2 is on is AIX.
Outstanding Contributor.

Re: HP SiteScope DB2 Monitor

Hi RYU123



Can you confirm which port the DB is listening on? I'm not too familiar with DB2, but I assume it probably has something similar to Oracle's TNS Listener that binds to a specific port.

If it's definitely port 50000, then it might be a firewall issue between your Sitescope server and the DB2 server. If it's another port though, you may need to change your connection string in the monitor's properties.


What does your current connection string look like more or less, is it something similar to "jdbc:db2://"?

If it does, you should be able to just specify a different port (the ":5021" portion) and try that.